Quick Guide
  User Guide (PDF)
  Demo
  WebEx Request
  Email & Phone Support
  Detective Troubleshooting
  FTP Instructions
  License Agreement
  Registration Info

 


 
 
 
    > Client Support > Quick Guide
 
   
  Quick Guide

Installing the Detective on Windows

Installing the Detective on Solaris

Detective Quick Reference and Overview

Detective User Guide

Using the Global Search Engine

Using Bookmarks & Notes

Adjusting Window to Fit Screen

 
 
product documentation & literature

 

 

Installing the On-Line! Detective on Windows
 
  1. Insert the On-Line! Detective CD-ROM in the CD-ROM drive. The install feature automatically starts the install process. It is recommended that any previous versions of the On-Line! Detective be removed prior to this installation.
  2. At the Welcome screen, click Next.
  3. At the Software License Agreement screen, read the Agreement and click Yes to continue with the installation or click No to terminate the install.
  4. Read the Installation Information screen and click Next.
  5. Enter the requested User Information and click Next. The registration number is located on the Registration form found with the product packaging.
  6. Click Yes to confirm the Registration Information or No to terminate the install.
  7. Click Next to accept the default Destination Folder, or use Browse to select a different Destination Folder.
  8. Click Next to accept the default Program Folder. The installation will begin.
  9. Click Finish to complete the installation process.
go to top

 

Installing the On-Line! Detective on Solaris

 
  1. Login to the system as root.

  2. Insert the On-Line! DetectiveŽ for Sun™ CD in the CD-ROM drive.

  3. Create a directory and mount the CD-ROM to it.
    Example: mkdir /cdrom

  4. Type df -k to confirm the available disk space.
    350 MB needed for the Professional Edition.

  5. Type /cdrom/sts/read.cd to execute the install script. Note: Depending on the automount configuration of the system, this step may not be necessary.

  6. Type 1 to select the Install Solaris Suite option.

  7. Type y to continue installation.

  8. Enter the desired install directory. Example: /opt This install script creates a softtech subdirectory under the install directory. Note: if a directory other than /opt is selected, see the Troubleshooting section to create a symbolic link.

  9. Type y to continue installation.

  10. Enter the requested User Information. The registration number is located on the Registration form found with the product packaging. On-Line! DetectiveŽ for Sun™ is extracted to the install directory.

  11. Type 3 to exit the installation upon completion.

  12. Type /<installpath>/softtech/on-line!. On-Line! DetectiveŽ for Sun™ displays.

go to top

 

Detective Navigation

 

Photographs
All photographs in the DetectiveŽ have “hot spots” with hyperlinked sub-menus. Click on any FRU (field replaceable unit) in the photograph and a menu of related options appears. Choose an option to hyperlink to a related topic.

Red Hyperlinks
All text, charts or numbers appearing in red are hyperlinks. Click on these items to link to more detailed and relevant information. To return to your original location, use the jump back button on the Navigation Bar to retrace your steps.

Site Map
For a quick view of the DetectiveŽ hierarchy, click on the Site Map hyperlink. The Site Map lists major modules contained within the DetectiveŽ. Click on a folder to go to that corresponding module.

Using Bookmarks and Notes
Use the Bookmarks... and Notes... options to create custom links or annotate often-referenced pages. To create a bookmark or note: See the On-Line! DetectiveŽ for Sun™ User Guide. 
Note: A PDF formatted version of the On-Line! DetectiveŽ for Sun™ User Guide is located in the DetectiveŽ root installation directory.

Table of Contents
Each module has a hyperlinked Table of Contents and an Alphabetical Index permitting single-click navigation.

Navigation Bar
Once in a module, utilize the Navigation push buttons to page-up, page-down, or jump back, to previous hyperlinks. Use the Contents button to display a pop-up menu of links to module-related topics.

Troubleshooting Procedures
Each Sun/SPARC System and Solaris module includes a Troubleshooting menu. This contains diagnostic reference data and unique troubleshooting techniques and tips.

go to top

 

Detective Overview

 

Menu Layout
The Main Menu of the DetectiveŽ provides access to various Sun/SPARC and Solaris modules. This includes an introduction, system overview, Boot PROM information, SCSI Device configuration, CPU/Peripheral modules (SBus, CPU, PCI, etc.) configuration, FRU Removal, and a host of other modules and important data for each specific system.

Part Number Information
Sun part and “X” options are hyperlinked to detailed information and replacement procedures. In addition to part numbers, the DetectiveŽ provides system compatibility and configuration requirements for Sun authorized and third-party products.

Tech Tips from the Experts
Tech Tips include hard-to-find information or undocumented problems encountered in real field repair situations. The Tech Tips cover a wide variety of topics including installations, upgrades, patches, hardware compatibility, operating system issues, and third-party peripherals. Accessing Tech Tips saves time and can eliminate hours of downtime and exhaustive searches on the Internet.

Search
Queries are used for quick retrieval of documents that have specific word or phrases. All documents containing text that matches a string of words of phrases in the Query text box are located and their titles are displayed for quick access. Wild card characters are also available — use an asterisk (*) for multiple character matches and question mark (?) for single character matches. NOTE: When searching for part numbers, use a space in place of a dash (-).

For more information, see the On-Line! DetectiveŽ for Sun™ User Guide and our website: www.itsupportal.com

go to top

 

Using the Search Engine

 

To Use the Search Engine:

  1. Click Search>Search on FrameViewer menu bar.
  2. When the Search Dialog box displays, key in a search string and press enter.
  3. When the document list appears, click on the desired document and press ENTER or click "Open" to display the document and text string.
  4. Use "Next", "First", "Last", or "Previous" buttons to find more results.
  5. Click Search>Preferences to display search "type" options.

Special note: The "Open" or ENTER button opens the searched document in a new window. Close the new, opened document when the search is complete and continue navigation from the original Detective window.

Part Number Search:
To search for PART NUMBERS, omit each "-" found in the number. For example, key in "501 1540" instead of "501-1540".

Options File: Links in the options file do not work when accessed via the search engine. To reach the option file, click Mainmenu>Part Numbers. Then select, the X Options folder.

Installation:

A) Default Installation of "softtech" Directory

Problems loading the search file may arise on initial use. In order for the search engine to function properly, the Detective must be installed in the default directory:

  • Windows: /softtech/ (where "/" is any hard drive or mapped network drive-softtech directory must be root level)
  • Solaris: /opt/softtech/ (where "/" is root-softtech directory must be in "opt" directory)

B) Installation in Custom Directory

The Detective's search engine is driven by a "search.dbs" file located in "/softtech/search" directory. In order to install "softtech" in a directory other than default (and use the search engine), the search.dbs file must be modified to reflect desired path.

go to top

 

Detective User Guide

 

Click Here to view User Guide

The User Guide is a PDF File and requires the free plug-in Acrobat Reader.

go to top

 

Using Bookmarks & Notes

 

Use the bookmarks and notes functions of the On-Line! Detective for Sun to link immediately to, or annotate often-referenced pages.

To create a bookmark:

  1. Go to paragraph to bookmark
  2. Hold down Control key while clicking in paragraph
  3. Choose Edit>New Bookmark
  4. Enter bookmark title
  5. Click Create to make bookmark
  6. Choose Bookmarks>Navigation>"your bookmark" to jump directly to bookmarked text

To create a note:

Go to paragraph to annotate. Hold down Control key while clicking in paragraph

  1. Choose Edit>New Note
  2. Enter note title and text
  3. Click Create to make note
  4. A small note icon appears near annotated text
  5. Click on this icon to view note
  6. View a list of all notes by choosing Navigation>Bookmark

Note: Bookmarks and notes from previous Detective versions will be deleted during the next update.

go to top

 

Adjusting Window to Fit Screen

 

If the window does not fit the screen or if the text is too big or too small, change the settings:

  1. Maximize program window (outer window)
  2. Maximize Detective window (inner window)
  3. At bottom right of Detective window, click on zoom setting (number with a % sign). Choose percentage of screen to view or choose "Fit Page in Window" and "Fit Window to Page" OR
  4. Click on zoom-in (Z) or zoom-out (z) button at right, bottom of window and then select "Fit Page in Window.
go to top